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Install Windows Server
· Install Windows server 2008 Standard 64bit onto your machine. If the server is hosted off site, it is more than likely that this install is done for you. 
As the machine is not going to have an Active Directory, keep it as part of the Workstation.
(Boot from Disk and Select English and UK keyboard input as well as time format).

[image: 5672]

· Click “Install Now”

[image: ]

· Select Server 2008 R2 Standard (Full Installation)

[image: ]

· Accept license agreement

[image: ]

· Select Custom (advanced)

[image: ]

· Select partition C:\ drive 
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· Wait for windows to install
[image: ]


· Click OK when prompted by warning message
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· Enter default password

[image: ]


· Click Start > (Right Click) Computer > Properties

[image: Description: 1]


· Click Remote settings     
 
[image: ]

· Select the radio button “Allow connections from computers running any version of remote desktop” 

[image: Description: 3]

· Click OK when warning sign appears
[image: ]

· Click Remote Settings and then click Select Users. Press the “Add” button

[image: Description: 4]

· Enter “Administrators” and “Everyone” and press check names to ensure correct spelling

[image: Description: 5]

· If these object have been entered correctly when the ‘check names’ button is clicked, then the following screen will appear.
(Press OK to close the Window)

[image: ]
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Install IIS and RDWeb
Open Server Manager

[image: ]

· Expand Role and click Add Roles, on Right Hand Panel.

[image: ]

· Click Next

[image: ]

· Select IIS and Remote Desktop Services

[image: ]

· The services needed for Remote Desktop Services are; 
Remote Desktop Session Host, 
Remote Desktop Licensing Manager and 
Remote Desktop Web access.

[image: ]
· When you click Remote Desktop Web Access you will be asked to add IIS features, these will be picked automatically for you, you just need to click Add Required Role Services.

[image: ]

· When installing, select: Do Not Require Network Authentication

[image: ]

· Run through the install using the default setting, select CAL’s as licence type.
 
[image: ]

· Click Next

[image: ]

· Click Next

[image: ]

· Click Next

[image: ]

· Click Next

[image: ]


· Click Install

[image: ]

· When prompted for a restart click Yes.

[image: ]

· Next, Open IIS, this is located from Start/Administrative Tools/Internet Information Services (IIS) Manager

[image: Description: 6]


· In IIS go to the Default Web site, and on the right hand column click Bindings

[image: ]
· Click Add and type in the name of the website

[image: ]

· In IIS, in the Default Web Page create a Redirect to https://<website>/RDWeb
· On the Default Web Site menu, open HTTP redirect

[image: Description: 7]

· Enter in the Details of the website, remembering to put “/RDWeb” on the end.
[image: ][image: ]
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Install ScadaPro Product

· Install Server and Site to Office along with 50 Client Licences on the server’s C:\ drive, as well as E:\Projects\ Application\Sources\Configurations\SAVED_CONFIG\STOReadingServer.zip.
 
· Copy over the CMONITORS.
 (These can be found in SourceSafe Projects\Application\STO Sources\Configurations\CMONITORS). 
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· Open ScadaPro folder and choose Server

[image: ]

















· Choose Setup.msi

[image: ]

· Ensure the proper Product bitmap (.bmp) is in place by opening it; you should see the image below:

[image: ]

· Click Next to continue through setup.

[image: ]

· Choose the type of key being used for installation (enter an Unlock Code if necessary)

[image: ]

· Agree to the License Agreement


[image: ]

· Click Next to install the Product

[image: ]

· Select Finish, ending the installation

[image: ]
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· Open the Client folder and select Setup.msi

[image: ]

· Install 50 Client Licenses (enter the Unlock key if required) 
to do this, simply click the ‘Change Drivers’ button.
[image: ]

[image: ]

· Continue through the installation and click Finish to end the installation.

[image: ]
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· Open up the Site to office folder

[image: ]

· Install Site To Office using the Setup.msi

[image: ]

· Enter in an Unlock code if required
[image: ]

· Set up the Default amount of Loggers

[image: ]

· Then, when prompted, click Finish to end the installation
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· Launch the Web Service Setup.msi and select Next.

[image: ]

· Select I accept the terms in the license agreement and select Next:

[image: ]


· Enter in the unlock key and select Next:

[image: ]

· Retain the default location for the installation in Destination Folder dialog, and click Next

[image: ]

· Click Install

[image: ]

· Click Finish
[image: ]
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· Type ‘regedit’ into the search bar on the start menu, or select the ‘Run’ program and type regedit. Click OK to run. (shown below)

[image: ]

· Navigate to: 

HKEY_LOCAL_MACHINE>SOFTWARE>WOW6432Node>Measuresoft>ScadaPro 

[image: ]

· Create a new String Value Key called DisableMonitorLock and the value is ON. 
Do this by right clicking on the left pane and choosing New/String Value

[image: ]

· Enter the String Name and value respectively

[image: ]

· Navigate to: HKEY_LOCAL_MACHINE>SOFTWARE>MEASURESOFT>SCADAPRO 

· Create a new DWORD Value called TagSize with value set to Decimal 8. Right Click on the pane again, this time selecting DWORD.
[image: ]
· Rename as “TagSize”, right click to modify and change the value to 8, the DWORD entry will then be shown as below.

[image: ]
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· Go to Start > Administrative Tools > Remote Desktop > Remote App Manager

[image: Description: 15]

· Click Add RemoteApp Programs from the right hand side panel

[image: ]

· Select UserProvisioning.exe

[image: ]

· Go to the RD Session Host Server Settings in the right hand pane

[image: Description: 17]

· Navigate to the RD session Host Server tab and change the server name to the server URL address.
[image: ]

· Under the Custom RDP Settings tab change the 2 to a 0

[image: Description: 18]

· Click OK then close Remote App Manager
· Go to Start > Administrative Tools > Computer Management

[image: Description: 19]

· In the left pane, expand Local Users and Groups, and then click Groups

[image: Description: 20]        
· In the right pane, double-click TS Web Access Computers
[image: ]
· In the TS Web Access Computers Properties dialog box, click Add to Group
[image: Description: 21]
· Add the name administrative account then OK and OK again
[image: Description: 22]
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· Open IIS and on the homepage double click Server Certificates.

[image: ]

· Select Create Certificate Request
· Fill out the Details form for the company, the Common Name is the name of the Web site sto.measuresoft.com, follow the Wizard to the end, this will create an encrypted text file
· Use text file to buy a secure site SSL certificate from VeriSign
· Install certificate by saving the file you get from VeriSign as a ‘.cer’, then go to Server Certificates in IIS and click complete certificate Request. (If this gives a problem, simply save the file extension as a .p7b and install it manually).

(To bind the Certificate to IIS, click Bindings, select Edit on the https bind and in the drop down box select the SSL certificate.)
	[image: ]
· Go to RemoteApp Manager, and click Digital Signature Settings

	[image: ]

Tick the box ‘Sign with a digital certificate, click change and select the new SSL certificate

	[image: ]
· Go to Remote Desktop Session Host Configuration.
· Follow: Start>Administrative Tools>Remote Desktop Services>Remote Desktop Session Host Configuration

[image: ]

· Right click RDP-Tcp and select properties. Then, under the General tab, select SSL in the
   security layer drop down box, click select and select the SSL cirtificate

[image: ]
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Time Restriction
· Open Remote Desktop Session Host Configuration by following:
· Start > Administrative Tools > Remote Desktop Services > Remote Desktop Session
Host Configuration

[image: Description: 23]

· Right click on RDP-Tcp and choose Properties

[image: Description: 24]

· Go to the Sessions Tab and set settings as shown
[image: ]
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· In initial set-up, a D: drive will need to be created. To complete this process, follow: 
Start > Administrative Tools > Computer Management.
From this window you then need to navigate to Disk Management:

[image: ]
· Right-Click on the Primary partition and choose “Shrink Volume”

[image: ]

· Choose the amount you want to shrink the disk by and select “Shrink”

[image: ]

· To create a D: drive right click on the new Unallocated space and select “New Simple Volume” 

[image: ]
· Follow the Wizard until completion and select the drive name to be Disk 1 when the option presents itself.  If this needs to be changed at anytime, simply go to my computer and rename the drive from there.

[image: ]

· A warning will come up informing you that you need to format the disk, format it and the D: drive will be ready for use.
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· Run Group Policy Editor by entering gpedit.msc into run.

[image: Description: 25]

· Go to: Local Computer Policy > Computer Configuration > Administrative Template > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection.

[image: ]








· Double Click on Allow Time Zone Redirection and select Enable

[image: ]
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Maintenance

· To view users that are logging data, simply open the session manager by following: Start > Administrative Tools > Share and Storage Management. 
Then click ‘Manage Session’ under the right hand Tab, and this will show who is logging.

[image: ]

[image: ]
· Also check the machine resources by going to resource monitor

[image: ]

				



















[bookmark: _Toc369182376][bookmark: _Toc369182412][bookmark: _Toc369602327]
Set Local User Policy

· To set the Local User Policy’s open up ‘Local User Policy’, then under ‘Security Settings’ select ‘Local Policies’ and Choose ‘User Rights Assignment’.

· In the policy list in the right hand pane, select ‘Impersonate a client after authentication’

    [image: ]

· Right click to select ‘Properties’.  In the ‘Local Security Settings’ tab add the UP_HIDDEN group and choose OK.

[image: ]
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Assign Apps
· It is not possible to assign a user to an App, through Remote App Manager without being part of a Domain first. This method allows you to manually add Users to Apps by tricking the Computer into thinking that it is a Domain.

[image: ]

[image: ]

· Click Start > Administrative Tools > Windows PowerShell Modules. To switch to the Remote Desktop Services module for Windows PowerShell, type cd RDS:\
[image: ]
· Type cd RDS:\RemoteApp\RemoteAppPrograms and then press ENTER. A dir command at this container lists all the applications that are published
[image: ]
· Type cd .\<app>\UserAssignment and then press ENTER. A dir command at this container lists all the users and groups to whom the application is assigned. (The example app below is assigned to everyone and therefore shows no users).
[image: ]
· To assign the application to a user, type New-Item -Path RDS:\RemoteApp\RemoteAppPrograms\<app>\UserAssignment -Name <user>@STO and then press ENTER
[image: ]
· To unassign the application to a user, type Remove-Item -Path 'RDS:\RemoteApp\RemoteAppPrograms\<app>\UserAssignment\<user>@STO' and then press ENTER. If you are removing the last user you must add –Force to this command, to do this type Remove-Item –Path –Force  'RDS:\RemoteApp\RemoteAppPrograms\<app>\UserAssignment\<user>@STO'
[image: ]
· Type dir and then press ENTER to see the user removed from the list of users
[image: ]
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User Provisioning Setup

In order to implement the user provisioning system you will need to do the following –
· Install ASP
· Install IIS6 Scripting Tools
· Install SMTP Virtual Server feature
· Configure Windows PowerShell
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If ASP Classic is not installed follow the steps below to do so.
· Log in as an administrator
· Open Server Manager and in the left pane, click Roles
· Scroll down in the right pane to Role Services and click Add Role Services

[image: ]

· Select ASP as shown below and click Next
[image: ]

· Verify installation details and click Install

[image: ]
· ASP will now install on the server. When installation is complete, click Close.

[image: ]

· ASP is now installed on the server.
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· Open server manager, in the left pane click Roles and scroll down in the right pane to Role Services.
· Click Add Role Service and scroll down to IIS6 Scripting Tools,  select it and click Next
[image: ]

· On the following prompt click Add Required Role Services

[image: ]


· Verify installation details and click Install

[image: ]

· When installation is completed, click Close

[image: ]
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This process details how to install the SMTP feature in Windows Server 2008 R2. This means that the server can be used as the SMTP server for the user provisioning system.

· Open Server Manager, by default the icon will be beside the start button, however if this not visible navigate to Administrative tools and select Server Manager, as shown below: 

 [image: ]

· When the Server Manager window has opened, select the features tab and from this window, select Add Features 
[image: ]

· From the next screen, choose to add SMTP Server 

[image: ]
· Add the required role services that appear and press next to install the SMTP Server feature.

[image: ]

· It is important to note that SMTP Server will not open with IIS 7.0 but with IIS 6 in compatibility mode, as such to access the SMTP settings, you need to navigate to Administrative Tools/Internet Information Services (IIS) 6.0 Manager.

[image: ]

· From IIS 6.0, expand the local computer to see the SMTP Virtual Server. If this is stopped, start it by right clicking and pressing start. Otherwise, right click on SMTP Virtual Server and choose properties.   
[image: ]

· From the properties menu, navigate to the Access tab and select Relay 
[image: ]

· From the pop-up menu, you need to select Add. 

[image: ]
· In this next menu, you need to type in the IP 127.0.0.1. This is a loopback IP that allows the server to relay messages. 

[image: ]

·  Select OK and apply the changes.
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· Go to start/Administrative Tools/Windows Power Shell Modules 

[image: Description: 26]

· Open Windows PowerShell

[image: ]

· Enter the following command: Set-Execution Policy Unrestricted
[image: ]

· Hit return and enter Y on the next screen and then hit return once more

[image: ]


· Verify the command worked by entering the command Get-Execution Policy into the terminal. Unrestricted should be returned.

[image: ]
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The User Provisioning folder contains all of the files needed to reset passwords on the server. The following steps will outline how to configure and install the password reset solution.

· Copy the User Provisioning folder to the server’s Desktop
· Copy the Reset folder to your C: Drive
[image: ]

· Copy the AdminScripts folder to C:\inetpub

[image: ]

· Copy the iisadmpwd folder to C:\Reset\

[image: Description: creset]
· Run an elevated command prompt. To do this, click the start menu and right click command prompt and click Run as Administrator 

[image: ]

· In the command prompt enter the following command and hit return regsvr32 c:\Reset\iisadmpwd\iispwchg.dll


[image: ]

· If the command was successful the following dialogue will appear

[image: ]

· If the command returns an error, copy the iispwchg.dll file to a new directory and run the command again, replacing the file path with the point of the new location.
· Open another elevated command prompt and follow the process is the same as before
· Change directory to c:\inetpub\AdminScripts and enter the following command and then hit return: cscript.exe adsutil.vbs set w3svc/passwordchangeflags 1
[image: ]

· If the command was successful the following result will display. If you get an error, please see section 1.2 of this document for installing IIS6 Scripting tools

[image: ]
· Next we will create a virtual application in IIS. Open IIS7 Manager Start > Administrative Tools > Internet Information Services (IIS) Manager. 
· Expand the website, right click the RDWeb application in the left pane and click “Add Application” as shown below
[image: ]

· Enter the details as shown below. Alias – passwordreset and Physical Path – c:\reset\iisadmpwd
[image: Description: add app]
· Click OK
· To verify the application was added successfully, select the passwordreset application in IIS and click “Content View” at the bottom to verify the files are in place

[image: ]

· Open the C:\ drive and right click the Reset folder, select Properties.

[image: ]
· Click the Security tab and click Edit

[image: ]

· Click Add
· Enter the user NETWORK SERVICE and click check names to verify

[image: ]

· Click OK

· Click the Network Service user and grant full control permissions

[image: ]

· Open test.ps1 in a text editor (notepad)
· Ensure the values for EmailFrom and SmtpServer are correct for the server
(EmailFrom should be noreply@companyname.com and SMTP server should be “10.101.3.5”)

[image: ]

· Open Server Manager
· Expand the Configuration menu on the left hand pane
· Expand Local Users and Groups
· Right click Users and select New User

[image: ]

· Enter a Username and enter a valid email address in the Description field. Set a password and set that the user’s password never expires. This account is used only for testing purposes. (Email must be a valid email address)
[image: ]

· Click Create and then Close. The user should now be visible in the user list.

[image: ]

· Click on Start > Administrative Tools > Local Security Policy.
[image: ]

· In Local Security Policy, click on Account Policies and then click on Password Policy. Under Password Policy, double click on “Password must meet complexity requirements” and then select the Disabled option.
[image: ]

· Then click Apply and then click OK.
· At this point open Internet Explorer and navigate to https://sto.measuresoft.com/rdweb/passwordreset/search.asp

[image: STO Password reset.jpg]

· Enter the test Username and email you created.

· Click Submit

[image: STO Password reset success.jpg]

· Navigate to the Reset folder in your C:\ drive, there should now be a text file named users.txt

[image: ]

· Open the file; it should contain the Username you entered, a new password and the email address. (An example of this is shown below)
Note: (If this file is empty, please check the permissions are set correctly.)

[image: ]

· Open Task Scheduler (Start menu – Administrative Tools – Task Scheduler)

[image: ]

· When Task Scheduler opens, click Create Task in the right hand pane

[image: ]

· Enter the Task information as shown below. Set the task to run whether the user is logged in or not and set to not store the password. Also set the task to run with highest privileges. 

[image: ]

· Click the Triggers tab along the top and click New. Now enter the information as shown below. The task is set to run on a daily schedule, repeating every 5 minutes indefinitely. Also enable the task.
[image: ]

· Click OK
· Select the Actions tab along the top and click New. Now enter the information as shown below. The task should run the pass.bat file located in the Reset folder

[image: ]

· Click OK
· Click OK again and you will be returned to the main Task Scheduler menu where you can verify your task has been scheduled.

[image: ]

· Right click the task and click Run

[image: ]

· When the task has completed, reopen the users.txt file located in the Reset folder of your C drive. The file should be empty

[image: ]

· Check the email you entered for the user, it should have a new message containing the reset password.
· Log out as administrator and log in as the test user using the new password.
· To change the password to something more memorable, open Internet Explorer and go to 
https://sto.measuresoft.com/RDWeb/passwordreset/password_change.asp
· Enter the username, the current password and the new password in the appropriate fields.

[image: Password change details.jpg]


· Click Submit
· If the operation was successful, the screen shown below will be displayed. If you receive an error message, try again taking care to enter the details correctly.

[image: ]

· Log out and log back in as the test user using the newly reset password.
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· Click Start > run > MMC and hit enter / click OK

[image: ]

· Select File > Add/Remove snap in...
[image: ]

· Select Group Policy Object Editor and Click "Add"

[image: ]

· Select Browse

[image: ]

· Select "Users" and then click on Non-Administrators and click OK

[image: ]

· Click Finish

[image: ]

· Click OK
[image: ]

· On the GPO editor select "User Configuration" and "Administrative Templates"

[image: ]

· Select "Desktop" and enable "Remove My Documents icon on the desktop” "Hide Network Locations icon on desktop" and "Remove Recycle Bin icon from desktop".
[image: ]

· Select "Start Menu and Taskbar" and enable the following:

	Add Logoff to the Start Menu
	Enable

	Remove drag-and-drop and context menus on the Start Menu
	Enable

	Remove and prevent access to the Shut Down, Restart, Sleep and Hibernate commands
	Enable

	Remove common program groups from Start Menu
	Enable

	Remove Favourites menu from Start Menu
	Enable

	Remove Search link from Start Menu
	Enable

	Remove frequent programs list from the Start Menu
	Enable

	Remove Games link from Start Menu
	Enable

	Remove Help menu from Start Menu
	Enable

	Remove All Programs list from the Start Menu
	Enable

	Remove Network Connection from Start Menu
	Enable

	Remove pinned programs list from the Start Menu
	Enable

	Do not keep history of recently opened documents
	Enable

	Remove Recent Items menu from Start Menu
	Enable

	Remove Run menu from Start Menu
	Enable

	Remove Default Programs link from the Start Menu
	Enable

	Remove Documents icon from Start Menu
	Enable

	Remove Music icon from Start Menu
	Enable

	Remove Network icon from Start Menu
	Enable

	Remove Pictures icon form Start Menu
	Enable

	Do not search communications
	Enable

	Remove Search Computer link
	Enable

	Remove See More Results / Search Everywhere link
	Enable

	Do not search for files
	Enable

	Do not search Internet
	Enable

	Do not search programs and Control Panel items
	Enable

	Remove programs on Setting menu
	Enable

	Prevent changes to Taskbar and Start Menu Settings
	Enable

	Remove Downloads link from Start Menu
	Enable

	Remove Homegroup link from Start Menu
	Enable

	Remove Recorded TV link from Start Menu
	Enable

	Remove links and access to Windows Update
	Enable

	Remove pinned programs from the Taskbar
	Enable



· Once these have been enabled, the Start Menu & Taskbar will look similar to this.

[image: ]


· To Hide the Taskbar right click on the taskbar and select properties
[image: ]

· In the properties window check "Auto-Hide the taskbar" and click "OK"

[image: ]

· In the Non-Administrator GPO enable "Prevent changes to Taskbar and Start Menu Settings"

[image: ]

· After that is set on the administrators account you did the auto hide on uncheck it again to bring the taskbar back for administrators.

[image: ]

(NOTE: No Reboot is required for these Settings and these setting only affect users that are not part of the Administrators group).
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· Copy Service.dll to the root of the product directory – C:\ScadaPro
· Copy Mod_Gsoap.dll to the bin directory - – C:\ScadaPro\bin
· Open IIS and configure:
i. Create the ScadaPro application in IIS – right click on Default Web Site and select Add Application – enter the details for ScadaPro
ii. Select the ScadaPro and choose Handler Mappings.  If you see the disabled section with two greyed out items – CGI-exe and ISAPI-dll, right click and select “Edit Feature Permissions” - Check Execute within that dialog.
[image: ]

iii. Within the Actions Pane select Add Script Map and enter details as per dialog below remember to select the executable location as per the product:

[image: ]

iv. Click Request Restrictions – On the Mapping Tab tick “Invoke handler only if request is mapped to:” and on the Access tab tick “Execute” . Click Ok and then Ok on the Add Script Map dialog.  The following warning will appear:
[image: ]

v. Click Yes to allow the ISAPI Extention.

vi. Return to the root of ScadaProin IIS and this time select Request Filitering. Enter the third tab Hidden Segments and delete the bin segment. 
vii. Restart IIS.
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· Open Internet Explorer and enter the following web address taking care to subsitute the IP address for your own machine.http://192.168.1.XXX/ScadaPro/bin/mod_gsoap.dll?service
	
· The following web page should appear:

[image: ]



Troubleshooting:
When using a 64-bit system, the web page will not be able to display by default as this is a 32-bit application. To change these settings and allow the web page to display, follow these steps:
· Open IIS 
· Expand the top menu and select “Application Pools” 
· Select DefaultAppPool
· Right-Click and choose Advanced Settings

[image: ]

· In the menu, under the General tab, set Enable 32-bit applications to True.
[image: ]

· Check that the application works in ScadaPro by going to Monitors/Channel Monitors/Configure. Type in your IP address and tab, you should now be able to view your channels.

Expro Logo not loading.

· The expro logo will not load if the image is not in the proper directory.  
· Locate the product bitmap file, located in ScadaPro/BIN and open with Paint. 
· Resize the object to approximately 390 pixels by 180 

[image: ]

· Save the resized image as “product_small.bmp” 
· Place the image into the BIN folder in ScadaPro.
0. [bookmark: _Toc369182387][bookmark: _Toc369182423][bookmark: _Toc369602338]
Set Compatibility Mode to Internet Explorer 9

Later versions of Internet Explorer (IE10+) will not display the remote desktop icons by default. This can be overcome by configuring IIS to run in compatibility mode.


This is accomplished by opening IIS and navigating to the RDWeb page. 

From here click on HTTP Header Response. [image: 2]

Then click “Add” from the right hand pane.

The next step is to give the new HTTP Response header a name of “X-UA-Compatible” and a value “IE=9” 

[image: 1]



Create Built-in Groups

· Administrators - allowed access to C:\ and D:\
· Regional Administrators - denied list access to D:\DATATODESK
· Field Users - added access to D:\DATATODESK
· Customers - denied list access to C:\ and D:\DATATODESK\REGION\COUNTRY

· Go to Run and type in “lusrmgr.msc”
[image: ]

· Right Click on the “Groups” folder and select “New group”

[image: ]

· Enter in the details for “Administrators” and click “Create”
[image: ]

· Enter in the details for “Regional Administrators” and click “Create”

[image: ]


· Enter in the details for “Field Users” and click “Create”
[image: ]

· Enter in the details for “Customers” and click “Create”

[image: ]




[bookmark: _Toc309151498][bookmark: _Toc369182388][bookmark: _Toc369182424][bookmark: _Toc369602339]Changing Group Policy 

· From the Start Menu, go to Run and type in “gpedit.msc”, press OK to bring up the Group Policy management console.

[image: ]

· When the Group Policy management console opens, follow the path: 
· Local Computer Policy > Computer Configuration > Windows settings > Security Settings > Local Policies > User Rights Assignment.

[image: ]

The policies that the groups need to be added to are: 
· Access this computer from the network
· Allow log on through Remote Desktop Services
· Increase a process working set
· Right Click on a policy and choose properties. 

[image: ]

· Select “Add User or Group”

[image: ]

· Select “Object Types”

[image: ]

· Deselect “Built-in security principals” and “Users” then select “Groups”
 
[image: ]

· Enter in the names of the Built In users

[image: ]

· Select “Check Names” to ensure the Built in group names are correct, they will then be underlined. Select OK
[image: ]

· Repeat the Group Policy process for both: “Allow log on through Remote Desktop Services” and “Increase a process working set”
[bookmark: _Toc369182389][bookmark: _Toc369182425][bookmark: _Toc369602340]Remove Inheritable Permissions

· To Remove Inheritable Permissions, right click on the folder you wish to change, and select properties.

[image: ]

· Navigate to the security tab and select “Advanced”

[image: ]

· Select the “Change Permissions” button

[image: ]

· Uncheck the “Replace all child object permissions with inheritable permissions from this object” box

[image: ]

[bookmark: _Toc369182390][bookmark: _Toc369182426][bookmark: _Toc369602341]Set folder permissions for Built-In Users

· Right Click on the C: drive and go to Properties.

[image: ]

· Go to the security tab and select “Edit”
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· Select the “Add” button

[image: ]

· Add “Global Administrators”, “Regional Administrators” and “Customers”. Press the check names button to ensure correct spelling

[image: ]


· Set permissions to match the following 
> Administrators to have ‘Full Control’ on folders
> Regional Administrators and Customers deny ‘List folder contents’ access 
(Examples of Administrator and Customer are shown below)





Administrator				         Customer
[image: ]     [image: ]

· Repeat this process, setting the same permissions on the “C:\Users” folder located in the C drive

[image: ]


· Set the same Permissions for the D drive, denying list folder content access to Customers and Regional administrators but allowing Full control to Administrators

[image: ]

· Go into the D drive and on the Site to office folder, right click and choose properties.

[image: ]

· From the security tab, give Full control to Administrators and deny List folder contents to regional Administrators and Customers

· Go in to the Site to office folder and select a region, in this example, we will select Asia:
[image: ]

· Right click and select properties, then navigate to the security tab.
· Allow Global Administrators and Regional Administrators full control 
· Deny Customers list folder access.

[image: ]

· Repeat this process for all regions

[bookmark: _Toc369182391][bookmark: _Toc369182427][bookmark: _Toc369602342]Prevent Field Users from having access to RDWeb 

· This section details how to stop users from having access to RDWeb. This will be done to stop people from logging in as a Field User
· To prevent access for Field Users follow these steps:

I. Go to Start/Administrative tools/IIS  
[image: ]

II. From IIS, expand all the folders until you find the RDWeb page. 
[image: ]

III. Right click on the RDWeb page and choose Edit Permissions 

[image: ]

IV. From here move to the security tab and choose Edit 
[image: ]

V. Select ‘Add’ to add the Field Users group to the set of permissions. 

[image: ]

VI. Change the permissions of the Loggers group to deny  Read & execute, List folder contents and Read permissions      
[image: ]

VII. Finally, to ensure that the permissions, have been configured correctly, try to log in to RDWeb as one of the ‘Loggers’ users. You should see a warning “You aren’t authorised to log on to this connection. Contact your systems administrator for authorisation”, as shown below. 

[image: ]
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